Network Outage
Resolved
Nov 30 at 05:00pm GMT
The network issue has been successfully resolved. We will be closely monitoring service performance to ensure there are no additional interruptions.
Affected services
Created
Nov 30 at 04:42pm GMT
We’re aware of a network outage impacting all UK services. Our team is working closely with our provider to restore connectivity as soon as possible. Thank you for your patience.
Please see the following link for more info:
https://status.innovacommunications.co.uk/cmilylo8c0c0rr0z8107jo8or
Affected services