Back to overview
Downtime
Network Outage
Jun 09 at 08:09pm BST
Affected services
Bravo
Resolved
Jun 09 at 09:21pm BST
Our network speeds have returned back to normal, Node will return shortly.
Affected services
Bravo
Created
Jun 09 at 08:09pm BST
We are currently investigating our Bravo node being unavaliable.
Affected services
Bravo