Back to overview
Downtime

Mail Server outage

Nov 20 at 07:57pm GMT
Affected services
mail.embotic.xyz

Resolved
Nov 20 at 08:03pm GMT

We have deployed a fix and our mail server is now functional.

Created
Nov 20 at 07:57pm GMT

We are aware of our mail server not working. We are currently investigating.